Frequency Mode: regulatory domain
Country: Your country
Channel Width: 20/40 MHz Ce
Frequency: Either 2412 / 2437 / 2462. You want to pick the least congested frequency - use the "Freq Usage" button as a quick test
SSID: Name of your wireless network
WMM Support: Enabled
WPS Mode: Disabled
Hit OK, then do the same things for wlan2 (the 5 GHz adapter). There are many more frequencies available in 5 GHz and some of them have special conditions for use. The "Auto" setting is probably a safe choice unless you know what you're doing. Be extra careful to make sure you've selected the correct country setting as some frequencies may be illegal to use otherwise!
Hit OK again, then go to the "Security Profiles" tab of the Wireless dialog. Click "default" and set the following:
Mode: Dynamic keys
Authentication Types: WPA2 PSK
Ciphers: aes ccm
WPA 2 Pre Shared Key: Your wireless password
Group Key Update: 01:00:00
This should leave you with a fully secured wireless network.
Go to System / Password and enter a password to secure the router's admin interface. You'll need this password to enter the configuration again in the future.
Go to IP / UPNP and tick Enabled. Click the Interfaces tab, then click Add New to add a new interface. Add ether1 (your internet) as an external interface. Hit OK, then Add New and add bridge-local as your internal interface. Enabling UPNP allows applications on your network to configure port forwarding automatically if needed.
Go to IP / DNS and enter 8.8.8.8 as your DNS server. This is Google DNS, which is usually faster and more reliable than your ISP DNS.
At this point you are pretty much set if all you want is a solid, stable router. The next steps will set up QoS to ensure smooth gaming and streaming.
This is where it starts to get a little complicated. Rather than explain everything involving the firewall, connection marking, packet tagging, queues, priorities, etc, I'm going to give you a bunch of commands that you should run. To run these commands, you'll need to download the "Winbox" app as it uses console commands that aren't available in the web interface. Press the "Winbox" button, which should download a copy of Winbox for you. Log in to the router using Winbox and you'll see it looks mostly the same as Webfig, but it's a bit more powerful.
Press the "New Terminal" button in Winbox and paste in the following (you can press Shift+Ins to paste into the terminal):
/queue tree
add limit-at=9700k max-limit=9700k name=queue1 parent=ether1-gateway queue=default
add limit-at=6200k max-limit=6200k name=prio5-streaming packet-mark=streaming parent=queue1 priority=5 queue=default
add limit-at=100k max-limit=9500k name=prio8-untagged packet-mark=no-mark parent=queue1 queue=default
add limit-at=1G max-limit=1G name=prio3-gaming packet-mark=gaming parent=queue1 priority=3 queue=default
add limit-at=1G max-limit=1G name=prio2-misc-fast packet-mark=misc-fast parent=queue1 priority=2 queue=default
add limit-at=100k max-limit=9500k name=prio6-http packet-mark=http parent=queue1 priority=6 queue=default
/ip firewall mangle add action=mark-packet chain=postrouting connection-mark=streaming new-packet-mark=streaming passthrough=no add action=mark-packet chain=postrouting connection-mark=gaming new-packet-mark=gaming passthrough=no add action=mark-packet chain=postrouting new-packet-mark=misc-fast packet-size=40 passthrough=no protocol=tcp tcp-flags=ack add action=mark-packet chain=postrouting dst-port=53 new-packet-mark=misc-fast out-interface=ether1-gateway passthrough=no protocol=udp add action=mark-packet chain=postrouting connection-mark=http new-packet-mark=http passthrough=no add action=mark-connection chain=postrouting comment=Streaming connection-state=new dst-port=1935 new-connection-mark=streaming out-interface=ether1-gateway protocol=tcp add action=mark-connection chain=postrouting comment=League dst-port=5000-5500 new-connection-mark=gaming out-interface=ether1-gateway protocol=udp add action=mark-connection chain=postrouting comment=SC2 dst-port=1119 new-connection-mark=gaming out-interface=ether1-gateway protocol=udp add action=mark-connection chain=postrouting comment=HotS dst-port=1120,3724 new-connection-mark=gaming out-interface=ether1-gateway protocol=udp add action=mark-connection chain=postrouting comment="BW + HotS" dst-port=6112-6113 new-connection-mark=gaming out-interface=ether1-gateway protocol=udp add action=mark-connection chain=postrouting comment="Valve Games" dst-port=27000-27060 new-connection-mark=gaming out-interface=ether1-gateway protocol=udp add action=mark-connection chain=postrouting comment="Web Browsing" connection-state=new dst-port=80,443 new-connection-mark=http out-interface=ether1-gateway protocol=tcp
After doing this, click on Queues / Queue Tree and double click queue1. You'll see the value 9700k - this should be replaced by a little under your upload speed, in kbps. The copy/paste code above is designed for someone with 10 mbps upload, so the maximum upload is limited to 9.7mbps (9700k). You want to limit it just under your max upload, otherwise there is a risk the upload will be queued on your modem instead, making all the QoS worthless. After setting your max upload on queue1, double click streaming and set it to a little over your maximum stream bitrate so that the stream bandwidth is smoothed out (the default above is for a 6000kbps stream). If you don't stream just ignore this - it won't hurt anything.
Next, double click http and no-mark and do the same there - replace 9500k with a number slightly less than the number you used for queue1. This will ensure big HTTP downloads and generic uncategorized traffic won't be able to hog the connection.
You're done! You now have a basic upload QoS, with supported games being StarCraft 2, Brood War, Valve Source based games (CS:GO, Dota 2, etc), Heroes of the Storm and League of Legends . Gaming and important small packets such as TCP acks and DNS get the highest priority, ensuring there's no lag even if the upstream is being heavily used. The next highest priority is outgoing stream data, so if you're streaming you won't get dropped frames caused by other uploads such as videos or torrents. If you want to add additional games, figure out what UDP ports the game uses and copy one of the existing "mark connection" rules like SC2, replacing the dst-port with the appropriate UDP ports.